What’s Vulnerable › Vulnerabilities

CVE-2024-47889: Action Mailer has possible ReDoS vulnerability in block_format

Description

Action Mailer is a framework for designing email service layers. Starting in version 3.0.0 and prior to versions 6.1.7.9, 7.0.8.5, 7.1.4.1, and 7.2.1.1, there is a possible ReDoS vulnerability in the block_format helper in Action Mailer. Carefully crafted text can cause the block_format helper to take an unexpected amount of time, possibly resulting in a DoS vulnerability. All users running an affected release should either upgrade to versions 6.1.7.9, 7.0.8.5, 7.1.4.1, or 7.2.1.1 or apply the relevant patch immediately. As a workaround, users can avoid calling the `block_format` helper or upgrade to Ruby 3.2. Ruby 3.2 has mitigations for this problem, so Rails applications using Ruby 3.2 or newer are unaffected. Rails 8.0.0.beta1 requires Ruby 3.2 or greater so is unaffected.

Affected products

How to fix

Upgrade to a fixed version: Ruby on Rails 6.1.7.9, 7.0.8.5, 7.1.4.1, 7.2.1.1; Rubygems Actionmailer 6.1.7.9, 7.0.8.5, 7.1.4.1, 7.2.1.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-47889 or the next vulnerability affects your stack