What’s Vulnerable › Vulnerabilities
CVE-2024-47911
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-04 · updated 2026-06-17
- Weakness: CWE-89
Description
In SonarSource SonarQube 10.4 through 10.5 before 10.6, a vulnerability was discovered in the authorizations/group-memberships API endpoint that allows SonarQube users with the administrator role to inject blind SQL commands.
Affected products
- SonarSource SonarQube: from 10.4 before 10.6 — fixed in 10.6
How to fix
Upgrade to a fixed version: SonarSource SonarQube 10.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-47911 or the next vulnerability affects your stack