What’s Vulnerable › Vulnerabilities
CVE-2024-47913
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-10-04 · updated 2026-06-17
- Weakness: CWE-532
Description
An issue was discovered in the AbuseFilter extension for MediaWiki before 1.39.9, 1.40.x and 1.41.x before 1.41.3, and 1.42.x before 1.42.2. An API caller can match a filter condition against AbuseFilter logs even if the caller is not authorized to view the log details for the filter.
Affected products
- Wikimedia Foundation MediaWiki: before 1.39.9; from 1.40.0 before 1.41.3; from 1.42.0 before 1.42.2 — fixed in 1.39.9, 1.41.3, 1.42.2
How to fix
Upgrade to a fixed version: Wikimedia Foundation MediaWiki 1.39.9, 1.41.3, 1.42.2. Check the vendor advisory for mitigations.
References
- https://gerrit.wikimedia.org/r/c/mediawiki/extensions/AbuseFilter/+/1076855
- https://phabricator.wikimedia.org/T372998
Get alerted when CVE-2024-47913 or the next vulnerability affects your stack