What’s Vulnerable › Vulnerabilities
CVE-2024-48019: Apache Doris: allows admin users to read arbitrary files through the REST API
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-04 · updated 2026-06-17
- Weakness: CWE-22
Description
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal'), Files or Directories Accessible to External Parties vulnerability in Apache Doris. Application administrators can read arbitrary files from the server filesystem through path traversal. Users are recommended to upgrade to version 2.1.8, 3.0.3 or later, which fixes the issue.
Affected products
- Apache Software Foundation Apache Doris: from 2.1.0 before 2.1.8; from 3.0.0 before 3.0.3 — fixed in 2.1.8, 3.0.3
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Doris 2.1.8, 3.0.3. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/p70klgmyrgknhn0t195261wvwv5jw6hr
- http://www.openwall.com/lists/oss-security/2025/02/04/2
Get alerted when CVE-2024-48019 or the next vulnerability affects your stack