What’s Vulnerable › Vulnerabilities
CVE-2024-48044: WordPress ShortPixel Image Optimizer plugin <= 5.6.3 - Broken Access Control vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-01 · updated 2026-06-17
- Weakness: CWE-862
Description
Missing Authorization vulnerability in ShortPixel ShortPixel Image Optimizer shortpixel-image-optimiser allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects ShortPixel Image Optimizer: from n/a through <= 5.6.3.
Affected products
- ShortPixel Image Optimizer: before 5.6.4 — fixed in 5.6.4
How to fix
Upgrade to a fixed version: ShortPixel Image Optimizer 5.6.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-48044 or the next vulnerability affects your stack