What’s Vulnerable › Vulnerabilities
CVE-2024-48080
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-03 · updated 2026-06-17
- Weakness: CWE-770
Description
An issue in aedes v0.51.2 allows attackers to cause a Denial of Service(DoS) via a crafted request. NOTE: the Supplier indicates that exploitation cannot occur because of the protection mechanism in the validateTopic function in lib/utils.js.
Affected products
- HackerOne aedes: from 0.51.2 before 0.51.3 — fixed in 0.51.3
How to fix
Upgrade to a fixed version: HackerOne aedes 0.51.3. Check the vendor advisory for mitigations.
References
- https://gist.github.com/mcollina/f06af2098665e4bb8372104425f3999e
- https://gist.github.com/pengwGit/cd3c1701a9e05b424fa6c60d86845de4
- https://github.com/moscajs/aedes/issues/1024
- https://github.com/moscajs/aedes/issues/1024#issuecomment-2671695219
- https://github.com/moscajs/aedes/releases/tag/v0.51.2
Get alerted when CVE-2024-48080 or the next vulnerability affects your stack