What’s Vulnerable › Vulnerabilities
CVE-2024-4811
- Severity: low (CVSS 2.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-25 · updated 2026-06-17
- Weakness: CWE-863
Description
In affected versions of Octopus Server under certain conditions, a user with specific role assignments can access restricted project artifacts.
Affected products
- Octopus Deploy Octopus Server: from 2023.1.4189 before 2023.4.8608; from 2024.1.437 before 2024.1.12759; from 2024.2.101 before 2024.2.9193 — fixed in 2023.4.8608, 2024.1.12759, 2024.2.9193
How to fix
Upgrade to a fixed version: Octopus Deploy Octopus Server 2023.4.8608, 2024.1.12759, 2024.2.9193. Check the vendor advisory for mitigations.
References
- https://advisories.octopus.com/post/2024/sa2024-05/
- https://advisories.octopus.com/post/2024/sa2024-05/
Get alerted when CVE-2024-4811 or the next vulnerability affects your stack