What’s Vulnerable › Vulnerabilities
CVE-2024-48208
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-10-24 · updated 2026-06-17
- Weakness: CWE-125
Description
pure-ftpd before 1.0.52 is vulnerable to Buffer Overflow. There is an out of bounds read in the domlsd() function of the ls.c file.
Affected products
- Pureftpd Pure-Ftpd: before 1.0.52 — fixed in 1.0.52
How to fix
Upgrade to a fixed version: Pureftpd Pure-Ftpd 1.0.52. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-48208 or the next vulnerability affects your stack