What’s Vulnerable › Vulnerabilities
CVE-2024-4835: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-05-23 · updated 2026-06-17
- Weakness: CWE-79
Description
A XSS condition exists within GitLab in versions 15.11 before 16.10.6, 16.11 before 16.11.3, and 17.0 before 17.0.1. By leveraging this condition, an attacker can craft a malicious page to exfiltrate sensitive user information.
Affected products
- GitLab: from 15.11.0 before 16.10.6; from 16.11.0 before 16.11.3; 17.0.0 — fixed in 16.10.6, 16.11.3
How to fix
Upgrade to a fixed version: GitLab 16.10.6, 16.11.3. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/gitlab/-/issues/461328
- https://hackerone.com/reports/2497024
- https://gitlab.com/gitlab-org/gitlab/-/issues/461328
- https://hackerone.com/reports/2497024
Get alerted when CVE-2024-4835 or the next vulnerability affects your stack