What’s Vulnerable › Vulnerabilities
CVE-2024-48514
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-24 · updated 2026-06-17
- Weakness: CWE-94
Description
php-heic-to-jpg <= 1.0.5 is vulnerable to code injection (fixed in 1.0.6). An attacker who can upload heic images is able to execute code on the remote server via the file name. As a result, the CIA is no longer guaranteed. This affects php-heic-to-jpg 1.0.5 and below.
Affected products
- Maestroerror Php-Heic-To-Jpg: through 1.0.5
References
- https://advisories.gitlab.com/pkg/composer/maestroerror/php-heic-to-jpg/CVE-2024-48514/
- https://github.com/MaestroError/php-heic-to-jpg
- https://github.com/advisories/GHSA-g8v9-c8m3-942v
- https://github.com/marcoris/CVEs/tree/master/CVE-2024-48514
Get alerted when CVE-2024-48514 or the next vulnerability affects your stack