What’s Vulnerable › Vulnerabilities
CVE-2024-4857: FS Product Inquiry <= 1.1.1 - Unauthenticated Stored XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-06-04 · updated 2026-06-17
- Weakness: CWE-79
Description
The FS Product Inquiry WordPress plugin through 1.1.1 does not sanitise and escape some form submissions, which could allow unauthenticated users to perform Stored Cross-Site Scripting attacks
Affected products
- FS Product Inquiry: before 1.1.1 — fixed in 1.1.1
How to fix
Upgrade to a fixed version: FS Product Inquiry 1.1.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/bf1b8434-b361-4666-9058-d9f08c09d083/
- https://wpscan.com/vulnerability/bf1b8434-b361-4666-9058-d9f08c09d083/
Get alerted when CVE-2024-4857 or the next vulnerability affects your stack