What’s Vulnerable › Vulnerabilities
CVE-2024-4866: UltraAddons – Elementor Addons (Header Footer Builder, Custom Font, Custom CSS,Woo Widget, Menu Builder, Anywhere Elementor Shortcode) <= 1.1.6 - Authenticated (Contributor+) Stored Cross-Site Scripting via Multiple Widgets
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-10 · updated 2026-06-17
- Weakness: CWE-79
Description
The UltraAddons – Elementor Addons (Header Footer Builder, Custom Font, Custom CSS,Woo Widget, Menu Builder, Anywhere Elementor Shortcode) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via multiple widgets in all versions up to, and including, 1.1.6 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. CVE-2024-37554 is potentially a duplicate of this.
Affected products
- Saiful Islam UltraAddons Elementor Lite: before 1.1.7 — fixed in 1.1.7
How to fix
Upgrade to a fixed version: Saiful Islam UltraAddons Elementor Lite 1.1.7. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/ultraaddons-elementor-lite/trunk/inc/widget/advance-pricing-table.php#L1340
- https://plugins.trac.wordpress.org/browser/ultraaddons-elementor-lite/trunk/inc/widget/hero-slider.php#L919
- https://plugins.trac.wordpress.org/browser/ultraaddons-elementor-lite/trunk/inc/widget/hotspot.php#L341
- https://plugins.trac.wordpress.org/browser/ultraaddons-elementor-lite/trunk/inc/widget/video-popup.php#L592
- https://plugins.trac.wordpress.org/browser/ultraaddons-elementor-lite/trunk/inc/widget/work-hour.php#L529
- https://plugins.trac.wordpress.org/changeset/3114007/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/544d7572-651f-45bb-b2ce-d768553c251a?source=cve
- https://plugins.trac.wordpress.org/browser/ultraaddons-elementor-lite/trunk/inc/widget/advance-pricing-table.php#L1340
- https://plugins.trac.wordpress.org/browser/ultraaddons-elementor-lite/trunk/inc/widget/hero-slider.php#L919
- https://plugins.trac.wordpress.org/browser/ultraaddons-elementor-lite/trunk/inc/widget/hotspot.php#L341
- https://plugins.trac.wordpress.org/browser/ultraaddons-elementor-lite/trunk/inc/widget/video-popup.php#L592
- https://plugins.trac.wordpress.org/browser/ultraaddons-elementor-lite/trunk/inc/widget/work-hour.php#L529
Get alerted when CVE-2024-4866 or the next vulnerability affects your stack