What’s Vulnerable › Vulnerabilities
CVE-2024-4868: Extensions for Elementor <= 2.0.32 - Authenticated (Contributor+) Stored Cross-Site Scripting via EE Events and EE Flipbox Widget
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-09 · updated 2026-06-17
- Weakness: CWE-79
Description
The Extensions for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's EE Events and EE Flipbox widgets in all versions up to, and including, 2.0.32 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- petesheppard84 Extensions for Elementor: before 2.0.32 — fixed in 2.0.32
How to fix
Upgrade to a fixed version: petesheppard84 Extensions for Elementor 2.0.32. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3121661/extensions-for-elementor/trunk/modules/events/widgets/ee-events.php
- https://plugins.trac.wordpress.org/changeset/3121661/extensions-for-elementor/trunk/modules/flipbox/widgets/ee-flipbox.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/4322d9d6-13b6-4476-9eb5-fea4aff2e5ce?source=cve
- https://plugins.trac.wordpress.org/browser/extensions-for-elementor/trunk/modules/events/widgets/ee-events.php#L2632
- https://plugins.trac.wordpress.org/browser/extensions-for-elementor/trunk/modules/flipbox/widgets/ee-flipbox.php#L1515
- https://www.wordfence.com/threat-intel/vulnerabilities/id/4322d9d6-13b6-4476-9eb5-fea4aff2e5ce?source=cve
Get alerted when CVE-2024-4868 or the next vulnerability affects your stack