What’s Vulnerable › Vulnerabilities
CVE-2024-4872
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-27 · updated 2026-06-17
- Weakness: CWE-943
Description
A vulnerability exists in the query validation of the MicroSCADA Pro/X SYS600 product. If exploited this could allow an authenticated attacker to inject code towards persistent data. Note that to successfully exploit this vulnerability an attacker must have a valid credential.
Affected products
- Hitachi Energy MicroSCADA Pro SYS600: 9.4-fixpack_2_hf1, 9.4-fixpack_2_hf2, 9.4-fixpack_2_hf3, 9.4-fixpack_2_hf4, 9.4-fixpack_2_hf5
- Hitachi Energy MicroSCADA X SYS600: from 10.0 before 10.6 — fixed in 10.6
How to fix
Upgrade to a fixed version: Hitachi Energy MicroSCADA X SYS600 10.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-4872 or the next vulnerability affects your stack