What’s Vulnerable › Vulnerabilities
CVE-2024-4874: Bricks Builder <= 1.9.8 - Insecure Direct Object Reference
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-22 · updated 2026-06-17
- Weakness: CWE-639
Description
The Bricks Builder plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 1.9.8 via the postId parameter due to missing validation on a user controlled key. This makes it possible for authenticated attackers, with Contributor-level access and above, to modify posts and pages created by other users including admins. As a requirement for this, an admin would have to enable access to the editor specifically for such a user or enable it for all users with a certain user account type.
Affected products
- Bricks Builder Bricks: before 1.9.9 — fixed in 1.9.9
How to fix
Upgrade to a fixed version: Bricks Builder Bricks 1.9.9. Check the vendor advisory for mitigations.
References
- https://bricksbuilder.io/release/bricks-1-9-9/#access-control-fix-for-user-role-contributor
- https://www.wordfence.com/threat-intel/vulnerabilities/id/6d63e898-43e5-42b5-96b6-1453352e0cae?source=cve
- https://bricksbuilder.io/release/bricks-1-9-9/#access-control-fix-for-user-role-contributor
- https://www.wordfence.com/threat-intel/vulnerabilities/id/6d63e898-43e5-42b5-96b6-1453352e0cae?source=cve
Get alerted when CVE-2024-4874 or the next vulnerability affects your stack