What’s Vulnerable › Vulnerabilities
CVE-2024-4876: HT Mega – Absolute Addons For Elementor <= 2.5.2 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-21 · updated 2026-06-17
- Weakness: CWE-79
Description
The HT Mega – Absolute Addons For Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘popover_header_text’ parameter in versions up to, and including, 2.5.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- devitemsllc HT Mega Addons for Elementor – Elementor Widgets & Template Builder: before 2.5.3 — fixed in 2.5.3
How to fix
Upgrade to a fixed version: devitemsllc HT Mega Addons for Elementor – Elementor Widgets & Template Builder 2.5.3. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/ht-mega-for-elementor/tags/2.5.0/includes/widgets/htmega_popover.php#L891
- https://plugins.trac.wordpress.org/changeset/3088899/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/39e104fa-591a-41e8-af7e-f8b32a199170?source=cve
- https://plugins.trac.wordpress.org/browser/ht-mega-for-elementor/tags/2.5.0/includes/widgets/htmega_popover.php#L891
- https://plugins.trac.wordpress.org/changeset/3088899/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/39e104fa-591a-41e8-af7e-f8b32a199170?source=cve
Get alerted when CVE-2024-4876 or the next vulnerability affects your stack