What’s Vulnerable › Vulnerabilities
CVE-2024-4877
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-03 · updated 2026-06-17
- Weakness: CWE-268
Description
OpenVPN version 2.4.0 through 2.6.10 on Windows allows an external, lesser privileged process to create a named pipe which the OpenVPN GUI component would connect to allowing it to escalate its privileges
Affected products
- OpenVPN: from 2.4.0 before 2.6.11 — fixed in 2.6.11
How to fix
Upgrade to a fixed version: OpenVPN 2.6.11. Check the vendor advisory for mitigations.
References
- https://community.openvpn.net/openvpn/wiki/CVE-2024-4877
- https://www.mail-archive.com/openvpn-users@lists.sourceforge.net/msg07634.html
Get alerted when CVE-2024-4877 or the next vulnerability affects your stack