What’s Vulnerable › Vulnerabilities
CVE-2024-4888: Arbitrary File Deletion in BerriAI/litellm
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-06-06 · updated 2026-06-17
- Weakness: CWE-862
Description
BerriAI's litellm, in its latest version, is vulnerable to arbitrary file deletion due to improper input validation on the `/audio/transcriptions` endpoint. An attacker can exploit this vulnerability by sending a specially crafted request that includes a file path to the server, which then deletes the specified file without proper authorization or validation. This vulnerability is present in the code where `os.remove(file.filename)` is used to delete a file, allowing any user to delete critical files on the server such as SSH keys, SQLite databases, or configuration files.
Affected products
- BerriAI litellm: before 1.35.19 — fixed in 1.35.19
How to fix
Upgrade to a fixed version: BerriAI litellm 1.35.19. Check the vendor advisory for mitigations.
References
- https://huntr.com/bounties/48461d89-cf13-4ad3-a43e-0d37da08fc6c
- https://huntr.com/bounties/48461d89-cf13-4ad3-a43e-0d37da08fc6c
Get alerted when CVE-2024-4888 or the next vulnerability affects your stack