What’s Vulnerable › Vulnerabilities
CVE-2024-48887
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 15.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-08 · updated 2026-06-17
- Weakness: CWE-620
Description
A unverified password change vulnerability in Fortinet FortiSwitch GUI may allow a remote unauthenticated attacker to change admin passwords via a specially crafted request
Affected products
- Fortinet FortiSwitch: from 6.4.0 before 6.4.15; from 7.0.0 before 7.0.11; from 7.2.0 before 7.2.9; from 7.4.0 before 7.4.5; 7.6.0 — fixed in 6.4.15, 7.0.11, 7.2.9, 7.4.5
How to fix
Upgrade to a fixed version: Fortinet FortiSwitch 6.4.15, 7.0.11, 7.2.9, 7.4.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-48887 or the next vulnerability affects your stack