What’s Vulnerable › Vulnerabilities
CVE-2024-4889: Code Injection in berriai/litellm
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-06-06 · updated 2026-06-17
- Weakness: CWE-94
Description
A code injection vulnerability exists in the berriai/litellm application, version 1.34.6, due to the use of unvalidated input in the eval function within the secret management system. This vulnerability requires a valid Google KMS configuration file to be exploitable. Specifically, by setting the `UI_LOGO_PATH` variable to a remote server address in the `get_image` function, an attacker can write a malicious Google KMS configuration file to the `cached_logo.jpg` file. This file can then be used to execute arbitrary code by assigning malicious code to the `SAVE_CONFIG_TO_DB` environment variable, leading to full system control. The vulnerability is contingent upon the use of the Google KMS feature.
Affected products
- BerriAI litellm: before 1.44.16 — fixed in 1.44.16
How to fix
Upgrade to a fixed version: BerriAI litellm 1.44.16. Check the vendor advisory for mitigations.
References
- https://huntr.com/bounties/be3fda72-a65b-4993-9a0e-7e0f05db51f8
- https://huntr.com/bounties/be3fda72-a65b-4993-9a0e-7e0f05db51f8
Get alerted when CVE-2024-4889 or the next vulnerability affects your stack