What’s Vulnerable › Vulnerabilities
CVE-2024-48911: OpenCanary Executes Commands From Potentially Writable Config File
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-14 · updated 2026-06-17
- Weakness: CWE-863
Description
OpenCanary, a multi-protocol network honeypot, directly executed commands taken from its config file. Prior to version 0.9.4, where the config file is stored in an unprivileged user directory but the daemon is executed by root, it’s possible for the unprivileged user to change the config file and escalate permissions when root later runs the daemon. Version 0.9.4 contains a fix for the issue.
Affected products
- thinkst opencanary: before 0.9.4 — fixed in 0.9.4
How to fix
Upgrade to a fixed version: thinkst opencanary 0.9.4. Check the vendor advisory for mitigations.
References
- https://github.com/thinkst/opencanary/commit/2c11575b1a3dd8b0df26a879ba856c0aa350c049
- https://github.com/thinkst/opencanary/releases/tag/v0.9.4
- https://github.com/thinkst/opencanary/security/advisories/GHSA-pf5v-pqfv-x8jj
Get alerted when CVE-2024-48911 or the next vulnerability affects your stack