What’s Vulnerable › Vulnerabilities
CVE-2024-48917: XXE in PHPSpreadsheet's XLSX reader
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-11-18 · updated 2026-06-17
- Weakness: CWE-611
Description
PhpSpreadsheet is a PHP library for reading and writing spreadsheet files. The `XmlScanner` class has a scan method which should prevent XXE attacks. However, in a bypass of the previously reported `CVE-2024-47873`, the regexes from the `findCharSet` method, which is used for determining the current encoding can be bypassed by using a payload in the encoding UTF-7, and adding at end of the file a comment with the value `encoding="UTF-8"` with `"`, which is matched by the first regex, so that `encoding='UTF-7'` with single quotes `'` in the XML header is not matched by the second regex. An attacker can bypass the sanitizer and achieve an XML external entity attack. Versions 1.9.4, 2.1.3, 2.3.2, and 3.4.0 fix the issue.
Affected products
- PHPOffice PhpSpreadsheet: before 1.29.4; from 2.0.0 before 2.1.3; from 2.2.0 before 2.3.2; from 3.3.0 before 3.4.0 — fixed in 1.29.4, 2.1.3, 2.3.2, 3.4.0
How to fix
Upgrade to a fixed version: PHPOffice PhpSpreadsheet 1.29.4, 2.1.3, 2.3.2, 3.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/PHPOffice/PhpSpreadsheet/blob/39fc51309181e82593b06e2fa8e45ef8333a0335/src/PhpSpreadsheet/Reader/Security/XmlScanner.php
- https://github.com/PHPOffice/PhpSpreadsheet/security/advisories/GHSA-7cc9-j4mv-vcjp
- https://owasp.org/www-community/vulnerabilities/XML_External_Entity_(XXE)_Processing
Get alerted when CVE-2024-48917 or the next vulnerability affects your stack