What’s Vulnerable › Vulnerabilities
CVE-2024-48933
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-09 · updated 2026-06-17
- Weakness: CWE-79
Description
A cross-site scripting (XSS) vulnerability in LemonLDAP::NG before 2.19.3 allows remote attackers to inject arbitrary web script or HTML into the login page via a username if userControl has been set to a non-default value that allows special HTML characters.
Affected products
- lemonldap-ng Lemonldap::Ng: before 2.19.3 — fixed in 2.19.3
How to fix
Upgrade to a fixed version: lemonldap-ng Lemonldap::Ng 2.19.3. Check the vendor advisory for mitigations.
References
- https://gitlab.ow2.org/lemonldap-ng/lemonldap-ng/-/issues/3232
- https://lists.debian.org/debian-lts-announce/2024/11/msg00037.html
Get alerted when CVE-2024-48933 or the next vulnerability affects your stack