What’s Vulnerable › Vulnerabilities
CVE-2024-48939
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-11 · updated 2026-06-17
- Weakness: CWE-922
Description
Insufficient validation performed on the REST API License file in Paxton Net2 before 6.07.14023.5015 (SR4) enables use of the REST API with an invalid License File. Attackers may be able to retrieve access-log data.
Affected products
- Paxton Net2: before 6.07.14023.5015 (SR4) — fixed in 6.07.14023.5015 (SR4)
How to fix
Upgrade to a fixed version: Paxton Net2 6.07.14023.5015 (SR4). Check the vendor advisory for mitigations.
References
- https://github.com/gitaware/CVE/blob/main/CVE-2024-48939/20241020_vuln_discl_paxton_API_license.pdf
- https://paxton-access.co.uk
- https://seclists.org/fulldisclosure/2024/Oct/3
- http://seclists.org/fulldisclosure/2024/Oct/3
Get alerted when CVE-2024-48939 or the next vulnerability affects your stack