What’s Vulnerable › Vulnerabilities
CVE-2024-48944: Apache Kylin: SSRF vulnerability in the diagnosis api
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-27 · updated 2026-06-17
- Weakness: CWE-918
Description
Server-Side Request Forgery (SSRF) vulnerability in Apache Kylin. Through a kylin server, an attacker may forge a request to invoke "/kylin/api/xxx/diag" api on another internal host and possibly get leaked information. There are two preconditions: 1) The attacker has got admin access to a kylin server; 2) Another internal host has the "/kylin/api/xxx/diag" api endpoint open for service. This issue affects Apache Kylin: from 5.0.0 through 5.0.1. Users are recommended to upgrade to version 5.0.2, which fixes the issue.
Affected products
- Apache Software Foundation Apache Kylin: from 5.0.0 before 5.0.2 — fixed in 5.0.2
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Kylin 5.0.2. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/1xxxtdfh9hzqsqgb1pd9grb8hvqdyc9x
- http://www.openwall.com/lists/oss-security/2025/03/27/5
Get alerted when CVE-2024-48944 or the next vulnerability affects your stack