What’s Vulnerable › Vulnerabilities
CVE-2024-48964
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-23 · updated 2026-06-17
- Weakness: CWE-78
Description
The package Snyk CLI before 1.1294.0 is vulnerable to Code Injection when scanning an untrusted Gradle project. The vulnerability can be triggered if Snyk test is run inside the untrusted project due to the improper handling of the current working directory name. Snyk recommends only scanning trusted projects.
Affected products
- snyk: before 1.1294.0 — fixed in 1.1294.0
How to fix
Upgrade to a fixed version: snyk 1.1294.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-48964 or the next vulnerability affects your stack