What’s Vulnerable › Vulnerabilities
CVE-2024-4899: SEOPress < 7.8 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-06-24 · updated 2026-06-17
- Weakness: CWE-79
Description
The SEOPress WordPress plugin before 7.8 does not sanitise and escape some of its Post settings, which could allow high privilege users such as contributor to perform Stored Cross-Site Scripting attacks.
Affected products
- SEOPress: before 7.8 — fixed in 7.8
How to fix
Upgrade to a fixed version: SEOPress 7.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/15346ae9-9a29-4968-a6a9-81d1116ac448/
- https://wpscan.com/vulnerability/15346ae9-9a29-4968-a6a9-81d1116ac448/
Get alerted when CVE-2024-4899 or the next vulnerability affects your stack