What’s Vulnerable › Vulnerabilities
CVE-2024-48990
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 21.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-19 · updated 2026-06-17
- Weakness: CWE-427
Description
Qualys discovered that needrestart, before version 3.8, allows local attackers to execute arbitrary code as root by tricking needrestart into running the Python interpreter with an attacker-controlled PYTHONPATH environment variable.
Affected products
- needrestart: before 3.8 — fixed in 3.8
How to fix
Upgrade to a fixed version: needrestart 3.8. Check the vendor advisory for mitigations.
References
- https://github.com/liske/needrestart/commit/fcc9a4401392231bef4ef5ed026a0d7a275149ab
- https://www.cve.org/CVERecord?id=CVE-2024-48990
- https://www.qualys.com/2024/11/19/needrestart/needrestart.txt
- http://seclists.org/fulldisclosure/2024/Nov/17
- https://lists.debian.org/debian-lts-announce/2024/11/msg00014.html
- https://www.openwall.com/lists/oss-security/2024/11/19/1
Get alerted when CVE-2024-48990 or the next vulnerability affects your stack