What’s Vulnerable › Vulnerabilities
CVE-2024-49006: SQL Server Native Client Remote Code Execution Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-12 · updated 2026-06-17
- Weakness: CWE-122
Description
SQL Server Native Client Remote Code Execution Vulnerability
Affected products
- Microsoft Sql Server 2016: from 13.0.6300.2 before 13.0.6455.2; from 13.0.7000.253 before 13.0.7050.2 — fixed in 13.0.6455.2, 13.0.7050.2
- Microsoft Sql Server 2017: from 14.0.1000.169 before 14.0.2070.1; from 14.0.3006.16 before 14.0.3485.1 — fixed in 14.0.2070.1, 14.0.3485.1
- Microsoft Sql Server 2019: from 15.0.2000.5 before 15.0.2130.3; from 15.0.4003.23 before 15.0.4410.1 — fixed in 15.0.2130.3, 15.0.4410.1
- Microsoft SQL Server 2016 Service Pack 3 Azure Connect Feature Pack: from 13.0.0 before 13.0.7050.2 — fixed in 13.0.7050.2
- Microsoft SQL Server 2016 Service Pack 3 (GDR): from 13.0.0 before 13.0.6455.2 — fixed in 13.0.6455.2
- Microsoft SQL Server 2017 (CU 31): from 14.0.0 before 14.0.3485.1 — fixed in 14.0.3485.1
- Microsoft SQL Server 2017 (GDR): from 14.0.0 before 14.0.2070.1 — fixed in 14.0.2070.1
- Microsoft SQL Server 2019 (CU 29): from 15.0.0 before 15.0.4410.1 — fixed in 15.0.4410.1
- Microsoft SQL Server 2019 (GDR): from 15.0.0 before 15.0.2130.3 — fixed in 15.0.2130.3
How to fix
Upgrade to a fixed version: Microsoft Sql Server 2016 13.0.6455.2, 13.0.7050.2; Microsoft Sql Server 2017 14.0.2070.1, 14.0.3485.1; Microsoft Sql Server 2019 15.0.2130.3, 15.0.4410.1; Microsoft SQL Server 2016 Service Pack 3 Azure Connect Feature Pack 13.0.7050.2; Microsoft SQL Server 2016 Service Pack 3 (GDR) 13.0.6455.2; Microsoft SQL Server 2017 (CU 31) 14.0.3485.1; Microsoft SQL Server 2017 (GDR) 14.0.2070.1; Microsoft SQL Server 2019 (CU 29) 15.0.4410.1; Microsoft SQL Server 2019 (GDR) 15.0.2130.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-49006 or the next vulnerability affects your stack