What’s Vulnerable › Vulnerabilities
CVE-2024-4901: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 33.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-27 · updated 2026-06-17
- Weakness: CWE-79
Description
An issue was discovered in GitLab CE/EE affecting all versions starting from 16.9 prior to 16.11.5, starting from 17.0 prior to 17.0.3, and starting from 17.1 prior to 17.1.1, where a stored XSS vulnerability could be imported from a project with malicious commit notes.
Affected products
- GitLab: from 16.9.0 before 16.11.5; from 17.0.0 before 17.0.3; 17.1.0 — fixed in 16.11.5, 17.0.3
How to fix
Upgrade to a fixed version: GitLab 16.11.5, 17.0.3. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/gitlab/-/issues/461773
- https://hackerone.com/reports/2500163
- https://gitlab.com/gitlab-org/gitlab/-/issues/461773
- https://hackerone.com/reports/2500163
Get alerted when CVE-2024-4901 or the next vulnerability affects your stack