What’s Vulnerable › Vulnerabilities
CVE-2024-49281: WordPress Click to Chat – WP Support All-in-One Floating Widget plugin <= 2.3.3 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-17 · updated 2026-06-17
- Weakness: CWE-78
Description
Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability in Ninja Team Click to Chat – WP Support All-in-One Floating Widget support-chat allows Stored XSS.This issue affects Click to Chat – WP Support All-in-One Floating Widget: from n/a through <= 2.3.3.
Affected products
- Ninja Team Click to Chat – WP Support All-in-One Floating Widget: before 2.3.4 — fixed in 2.3.4
How to fix
Upgrade to a fixed version: Ninja Team Click to Chat – WP Support All-in-One Floating Widget 2.3.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-49281 or the next vulnerability affects your stack