What’s Vulnerable › Vulnerabilities
CVE-2024-49337: IBM OpenPages HTML injection
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-20 · updated 2026-06-17
- Weakness: CWE-80
Description
IBM OpenPages with Watson 8.3 and 9.0 IBM OpenPages is vulnerable to HTML injection, caused by improper validation of user-supplied input of text fields used to construct workflow email notifications. A remote authenticated attacker could exploit this vulnerability using HTML tags in a text field of an object to inject malicious script into an email which would be executed in a victim's mail client within the security context of the OpenPages mail message. An attacker could use this for phishing or identity theft attacks.
Affected products
- IBM OpenPages with Watson: from 8.3 before 8.3.0.3; from 9.0 before 9.0.0.5 — fixed in 8.3.0.3, 9.0.0.5
How to fix
Upgrade to a fixed version: IBM OpenPages with Watson 8.3.0.3, 9.0.0.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-49337 or the next vulnerability affects your stack