What’s Vulnerable › Vulnerabilities
CVE-2024-4934: Quiz And Survey Master < 9.0.2 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-01 · updated 2026-06-17
- Weakness: CWE-79
Description
The Quiz and Survey Master (QSM) WordPress plugin before 9.0.2 does not validate and escape some of its Quiz fields before outputting them back in a page/post where the Quiz is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
Affected products
- ExpressTech Quiz And Survey Master: before 9.0.2 — fixed in 9.0.2
How to fix
Upgrade to a fixed version: ExpressTech Quiz And Survey Master 9.0.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/a2270ee1-3211-4b16-b3d7-6cdd732f7155/
- https://wpscan.com/vulnerability/a2270ee1-3211-4b16-b3d7-6cdd732f7155/
Get alerted when CVE-2024-4934 or the next vulnerability affects your stack