What’s Vulnerable › Vulnerabilities
CVE-2024-4936: Canto <= 3.0.8 - Unauthenticated Remote File Inclusion
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-14 · updated 2026-06-17
- Weakness: CWE-98
Description
The Canto plugin for WordPress is vulnerable to Remote File Inclusion in all versions up to, and including, 3.0.8 via the abspath parameter. This makes it possible for unauthenticated attackers to include remote files on the server, resulting in code execution. This required allow_url_include to be enabled on the target site in order to exploit.
Affected products
- flightbycanto Canto: before 3.0.9 — fixed in 3.0.9
How to fix
Upgrade to a fixed version: flightbycanto Canto 3.0.9. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/canto/trunk/includes/lib/sizes.php#L15
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3105443%40canto&new=3104074%40canto&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/95a68ae0-36da-499b-a09d-4c91db8aa338?source=cve
- https://plugins.trac.wordpress.org/browser/canto/trunk/includes/lib/sizes.php#L15
- https://www.wordfence.com/threat-intel/vulnerabilities/id/95a68ae0-36da-499b-a09d-4c91db8aa338?source=cve
Get alerted when CVE-2024-4936 or the next vulnerability affects your stack