What’s Vulnerable › Vulnerabilities
CVE-2024-49381: Plenti arbitrary file deletion vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-10-25 · updated 2026-06-17
- Weakness: CWE-74
Description
Plenti, a static site generator, has an arbitrary file deletion vulnerability in versions prior to 0.7.2. The `/postLocal` endpoint is vulnerable to an arbitrary file write deletion when a plenti user serves their website. This issue may lead to information loss. Version 0.7.2 fixes the vulnerability.
Affected products
- plentico plenti: before 0.7.2 — fixed in 0.7.2
How to fix
Upgrade to a fixed version: plentico plenti 0.7.2. Check the vendor advisory for mitigations.
References
- https://github.com/plentico/plenti/blob/01825e0dcd3505fac57adc2edf29f772d585c008/cmd/serve.go#L205
- https://github.com/plentico/plenti/releases/tag/v0.7.2
- https://securitylab.github.com/advisories/GHSL-2024-297_GHSL-2024-298_plenti/
Get alerted when CVE-2024-49381 or the next vulnerability affects your stack