What’s Vulnerable › Vulnerabilities
CVE-2024-49521: Adobe Commerce | Server-Side Request Forgery (SSRF) (CWE-918)
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-12 · updated 2026-06-17
- Weakness: CWE-918
Description
Adobe Commerce versions 3.2.5 and earlier are affected by a Server-Side Request Forgery (SSRF) vulnerability that could lead to a security feature bypass. A low privileged attacker could exploit this vulnerability to send crafted requests from the vulnerable server to internal systems, which could result in the bypassing of security measures such as firewalls. Exploitation of this issue does not require user interaction.
Affected products
- Adobe Commerce: before 3.2.6 — fixed in 3.2.6
- Adobe Magento: before 3.2.6 — fixed in 3.2.6
How to fix
Upgrade to a fixed version: Adobe Commerce 3.2.6; Adobe Magento 3.2.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-49521 or the next vulnerability affects your stack