What’s Vulnerable › Vulnerabilities
CVE-2024-49535: Acrobat Reader | Improper Restriction of XML External Entity Reference ('XXE') (CWE-611)
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-10 · updated 2026-06-17
- Weakness: CWE-611
Description
Acrobat Reader versions 24.005.20307, 24.001.30213, 24.001.30193, 20.005.30730, 20.005.30710 and earlier are affected by an Improper Restriction of XML External Entity Reference ('XXE') vulnerability that allows an attacker to provide malicious XML input containing a reference to an external entity, potentially leading to unauthorized read access outside the Acrobat sandbox. Exploitation of this issue requires user interaction in that a victim must process a malicious XML document.
Affected products
- Adobe Acrobat for Edge: from 20.001.30002 before 20.005.30748; from 24.0.0 before 24.001.30225 — fixed in 20.005.30748, 24.001.30225
- Adobe Acrobat DC: before 24.005.20320 — fixed in 24.005.20320
- Adobe Acrobat Reader: from 20.001.30002 before 20.005.30748 — fixed in 20.005.30748
- Adobe Acrobat Reader: before 24.005.20320 — fixed in 24.005.20320
How to fix
Upgrade to a fixed version: Adobe Acrobat for Edge 20.005.30748, 24.001.30225; Adobe Acrobat DC 24.005.20320; Adobe Acrobat Reader 20.005.30748; Adobe Acrobat Reader 24.005.20320. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-49535 or the next vulnerability affects your stack