What’s Vulnerable › Vulnerabilities
CVE-2024-49537: After Effects | Stack-based Buffer Overflow (CWE-121)
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-10 · updated 2026-06-17
- Weakness: CWE-121
Description
After Effects versions 24.6.2, 25.0.1 and earlier are affected by a Stack-based Buffer Overflow vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe After Effects: before 24.6.3; from 25.0 before 25.1 — fixed in 24.6.3, 25.1
How to fix
Upgrade to a fixed version: Adobe After Effects 24.6.3, 25.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-49537 or the next vulnerability affects your stack