What’s Vulnerable › Vulnerabilities
CVE-2024-49552: Media Encoder | Heap-based Buffer Overflow (CWE-122)
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-10 · updated 2026-06-17
- Weakness: CWE-122
Description
Media Encoder versions 25.0, 24.6.3 and earlier are affected by a Heap-based Buffer Overflow vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe Media Encoder: before 24.6.3; 25.0 — fixed in 24.6.3
How to fix
Upgrade to a fixed version: Adobe Media Encoder 24.6.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-49552 or the next vulnerability affects your stack