What’s Vulnerable › Vulnerabilities
CVE-2024-49589: Foundry artifacts denial of service
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-18 · updated 2026-06-17
- Weakness: CWE-770
Description
Foundry Artifacts was found to be vulnerable to a Denial Of Service attack due to disk being potentially filled up based on an user supplied argument (size).
Affected products
- Palantir com.palantir.artifacts:artifacts: before 0.1337.0 — fixed in 0.1337.0
How to fix
Upgrade to a fixed version: Palantir com.palantir.artifacts:artifacts 0.1337.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-49589 or the next vulnerability affects your stack