What’s Vulnerable › Vulnerabilities
CVE-2024-49628: WordPress Most And Least Read Posts Widget plugin <= 2.5.18 - Cross Site Request Forgery (CSRF) vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-20 · updated 2026-06-17
- Weakness: CWE-352
Description
Cross-Site Request Forgery (CSRF) vulnerability in whiletrue Most And Least Read Posts Widget most-and-least-read-posts-widget allows Cross Site Request Forgery.This issue affects Most And Least Read Posts Widget: from n/a through <= 2.5.18.
Affected products
- whiletrue Most And Least Read Posts Widget: before 2.5.19 — fixed in 2.5.19
How to fix
Upgrade to a fixed version: whiletrue Most And Least Read Posts Widget 2.5.19. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-49628 or the next vulnerability affects your stack