What’s Vulnerable › Vulnerabilities
CVE-2024-49629: WordPress Endless Posts Navigation plugin <= 2.2.7 - CSRF to Stored XSS vulnerability
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-20 · updated 2026-06-17
- Weakness: CWE-352
Description
Cross-Site Request Forgery (CSRF) vulnerability in Fahad Mahmood Endless Posts Navigation endless-posts-navigation allows Stored XSS.This issue affects Endless Posts Navigation: from n/a through <= 2.2.7.
Affected products
- Fahad Mahmood Endless Posts Navigation: before 2.2.8 — fixed in 2.2.8
How to fix
Upgrade to a fixed version: Fahad Mahmood Endless Posts Navigation 2.2.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-49629 or the next vulnerability affects your stack