What’s Vulnerable › Vulnerabilities
CVE-2024-49633: WordPress DirectoryPress plugin <= 3.6.19 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-07 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Designinvento DirectoryPress directorypress allows Reflected XSS.This issue affects DirectoryPress: from n/a through <= 3.6.19.
Affected products
- Designinvento DirectoryPress: before 3.6.20 — fixed in 3.6.20
How to fix
Upgrade to a fixed version: Designinvento DirectoryPress 3.6.20. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-49633 or the next vulnerability affects your stack