What’s Vulnerable › Vulnerabilities
CVE-2024-49685: WordPress Custom Twitter Feeds plugin <= 2.2.3 - Cross Site Request Forgery (CSRF) vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-31 · updated 2026-06-17
- Weakness: CWE-352
Description
Cross-Site Request Forgery (CSRF) vulnerability in Syed Balkhi Custom Twitter Feeds (Tweets Widget) custom-twitter-feeds allows Cross Site Request Forgery.This issue affects Custom Twitter Feeds (Tweets Widget): from n/a through <= 2.2.3.
Affected products
- smub Custom Twitter Feeds – A Tweets Widget or X Feed Widget: before 2.2.4 — fixed in 2.2.4
How to fix
Upgrade to a fixed version: smub Custom Twitter Feeds – A Tweets Widget or X Feed Widget 2.2.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-49685 or the next vulnerability affects your stack