What’s Vulnerable › Vulnerabilities
CVE-2024-49696: WordPress Photo Gallery, Images, Slider in Rbs Image Gallery plugin <= 3.2.21 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-24 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in robosoft Robo Gallery robo-gallery allows Stored XSS.This issue affects Robo Gallery: from n/a through <= 3.2.21.
Affected products
- Photo Gallery, Images, Slider in Rbs Image Gallery: before 3.2.22 — fixed in 3.2.22
How to fix
Upgrade to a fixed version: Photo Gallery, Images, Slider in Rbs Image Gallery 3.2.22. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-49696 or the next vulnerability affects your stack