What’s Vulnerable › Vulnerabilities
CVE-2024-49754: LibreNMS has a stored XSS ('Cross-site Scripting') in librenms/includes/html/pages/api-access.inc.php
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 73.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-11-15 · updated 2026-06-17
- Weakness: CWE-79
Description
LibreNMS is an open-source, PHP/MySQL/SNMP-based network monitoring system. A Stored Cross-Site Scripting (XSS) vulnerability in the API-Access page allows authenticated users to inject arbitrary JavaScript through the "token" parameter when creating a new API token. This vulnerability can result in the execution of malicious code in the context of other users' sessions, compromising their accounts and enabling unauthorized actions. This vulnerability is fixed in 24.10.0.
Affected products
- librenms: before 24.10.0 — fixed in 24.10.0
How to fix
Upgrade to a fixed version: librenms 24.10.0. Check the vendor advisory for mitigations.
References
- https://github.com/librenms/librenms/commit/25988a937cbaebd2ba4c0517510206c404dfb359
- https://github.com/librenms/librenms/security/advisories/GHSA-gfwr-xqmj-j27v
Get alerted when CVE-2024-49754 or the next vulnerability affects your stack