What’s Vulnerable › Vulnerabilities
CVE-2024-49763: PlexRipper allows API leak due to open CORS policy
- Severity: high (CVSS 8.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-02 · updated 2026-06-17
- Weakness: CWE-942
Description
PlexRipper is a cross-platform media downloader for Plex. PlexRipper’s open CORS policy allows attackers to gain sensitive information from PlexRipper by getting the user to access the attacker’s domain. This allows an attacking website to access the /api/PlexAccount endpoint and steal the user’s Plex login. This vulnerability is fixed in 0.24.0.
Affected products
- Plexripper Project Plexripper: before 0.24.0 — fixed in 0.24.0
How to fix
Upgrade to a fixed version: Plexripper Project Plexripper 0.24.0. Check the vendor advisory for mitigations.
References
- https://github.com/PlexRipper/PlexRipper/commit/184074644a1f5a8ac59519929a9c4b92280fb2a1
- https://securitylab.github.com/advisories/GHSL-2024-305_PlexRipper/
Get alerted when CVE-2024-49763 or the next vulnerability affects your stack