What’s Vulnerable › Vulnerabilities
CVE-2024-49764: LibreNMS has a Stored XSS ('Cross-site Scripting') in librenms/includes/html/pages/device/capture.inc.php
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-11-15 · updated 2026-06-17
- Weakness: CWE-79
Description
LibreNMS is an open-source, PHP/MySQL/SNMP-based network monitoring system. A Stored Cross-Site Scripting (XSS) vulnerability in the "Capture Debug Information" page allows authenticated users to inject arbitrary JavaScript through the "hostname" parameter when creating a new device. This vulnerability results in the execution of malicious code when the "Capture Debug Information" page is visited, redirecting the user and sending non-httponly cookies to an attacker-controlled domain. This vulnerability is fixed in 24.10.0.
Affected products
- librenms: before 24.10.0 — fixed in 24.10.0
How to fix
Upgrade to a fixed version: librenms 24.10.0. Check the vendor advisory for mitigations.
References
- https://github.com/librenms/librenms/commit/af15eabbb1752985d36f337cecf137a947e170f6
- https://github.com/librenms/librenms/security/advisories/GHSA-rmr4-x6c9-jc68
Get alerted when CVE-2024-49764 or the next vulnerability affects your stack