What’s Vulnerable › Vulnerabilities
CVE-2024-49774: ModuleScanner flaws in SuiteCRM
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-05 · updated 2026-06-17
- Weakness: CWE-20
Description
SuiteCRM is an open-source, enterprise-ready Customer Relationship Management (CRM) software application. SuiteCRM relies on the blacklist of functions/methods to prevent installation of malicious MLPs. But this checks can be bypassed with some syntax constructions. SuiteCRM uses token_get_all to parse PHP scripts and check the resulted AST against blacklists. But it doesn't take into account all scenarios. This issue has been addressed in versions 7.14.6 and 8.7.1. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- salesagility SuiteCRM: before 7.14.6; from 8.0.0 before 8.7.1 — fixed in 7.14.6, 8.7.1
How to fix
Upgrade to a fixed version: salesagility SuiteCRM 7.14.6, 8.7.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-49774 or the next vulnerability affects your stack