What’s Vulnerable › Vulnerabilities

CVE-2024-49785: IBM watsonx.ai cross-site scripting

Description

IBM watsonx.ai 1.1 through 2.0.3 and IBM watsonx.ai on Cloud Pak for Data 4.8 through 5.0.3 is vulnerable to cross-site scripting. This vulnerability allows an authenticated user to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session.

Affected products

How to fix

Upgrade to a fixed version: IBM watsonx.ai 2.1.0; IBM watsonx.ai on Cloud Pak for Data 5.1.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-49785 or the next vulnerability affects your stack